A fix has been implemented and we are monitoring the results.
Posted May 15, 2026 - 18:09 EDT
Investigating
We are experiencing a partial outage affecting careers pages due to increased server load. Our teams are actively working to resolve the issue as quickly as possible.
Posted May 15, 2026 - 14:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2026 - 12:53 EDT
Investigating
We are experiencing higher than normal traffic, resulting in intermittent slowness in parts of the Recruiting platform. Some users may encounter slower page load times. Investigation in progress.
Posted May 15, 2026 - 12:13 EDT
This incident affected: Dashboard and Career Pages.