Outbound Email Deliverability Delays

Incident Report for Paycor Recruiting

Resolved

This incident has been resolved.
Posted May 01, 2024 - 18:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2024 - 17:20 EDT

Update

We are continuing to investigate this issue.
Posted May 01, 2024 - 13:38 EDT

Investigating

We have identified an issue with our 3rd party email provider that is impacting email deliverability times. Our teams are working diligently with our partners to resolve this issue promptly.
Posted May 01, 2024 - 13:09 EDT
This incident affected: Outbound Email.