Heavier than normal traffic load

Incident Report for Paycor Recruiting

Resolved

This incident has been resolved.
Posted Sep 09, 2024 - 14:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2024 - 14:04 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2024 - 10:00 EDT

Investigating

We are experiencing heavier than normal traffic load, leading to system slowness in some parts of the Recruiting platform. We are currently investigating the issue.
Posted Sep 09, 2024 - 10:00 EDT
This incident affected: Dashboard.