Paycor Recruiting Login Page Issues
Incident Report for Paycor Recruiting
Resolved
We identified the root cause of the login page failures and implemented a system update to restore client access to the login page (https://recruitingbypaycor.com/login). Users can successfully access the login page and log into the Recruiting system now.
Posted Oct 07, 2020 - 16:32 EDT
Investigating
We are currently investigating an issue where some users are unable to successfully access the login page for Paycor Recruiting (https://recruitingbypaycor.com/login). We will provide additional updates as soon as more information is available.
Posted Oct 07, 2020 - 15:22 EDT
This incident affected: Dashboard.