Heavier than Normal Traffic Load

Incident Report for Paycor Recruiting

Resolved

This incident has been resolved.
Posted May 14, 2025 - 18:41 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 18:17 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 18:14 EDT

Investigating

We are experiencing heavier than normal traffic load, leading to system slowness in some parts of the Recruiting platform. We are currently investigating the issue.
Posted May 14, 2025 - 17:54 EDT
This incident affected: Dashboard, Analytics, and Candidate and Job Search.