We are experiencing issues sending out offer letters with DocuSign, due to issues at DocuSign.
Incident Report for Paycor Recruiting
Resolved
This incident has been resolved.
Posted May 24, 2022 - 19:38 EDT
Monitoring
DocuSign service appears to be recovered.
Posted May 24, 2022 - 19:03 EDT
Investigating
We are currently investigating the issue.

Please keep an eye out for updates from DocuSign: https://status.docusign.com/
Posted May 24, 2022 - 17:16 EDT
This incident affected: Outbound Email.